Ασκήσεις στην επαναληπτική δομή ΓΙΑ

[1] Αντιγράψτε τον παρακάτω αλγόριθμο στον Διερμηνευτή. Τι θα εμφανίσει;

 

Αλγόριθμος παράδειγμα

   Άθροισμα <- 0

   Για χ από 10 μέχρι 4 με_βήμα 0

       Άθροισμα <- Άθροισμα + χ

   Τέλος_επανάληψης

   Εμφάνισε Άθροισμα

Τέλος παράδειγμα


[2] Να αναπτύξετε αλγόριθμο ο οποίος θα υπολογίζει και θα εμφανίζει το παραγοντικό ενός αριθμού. Υπενθυμίζεται ότι π.χ. το 5! υπολογίζεται ως εξής: 5*4*3*2*1=120


[3] Να αναπτύξετε αλγόριθμο ο οποίος θα εμφανίζει τις τιμές της συνάρτησης f(x)=4log(5+e3x + 2) όταν το x παίρνει τις τιμές στο διάστημα [10, 50] με βήμα 0,5. (Πρόκειται για την άσκηση 29 από τη σελ. 52 του σχολικού βιβλίου. Επίσης, στο περιθώριο της σελ. 34 του βιβλίου αναφέρονται οι συναρτήσεις που χρειάζεστε.)


[4] Στο νέο πληροφοριακό σύστημα ενός βιβλιοπωλείου πρόκειται να καταχωρηθούν 150 νέα βιβλία. Για κάθε βιβλίο καταχωρείται ο τίτλος, ο συγγραφέας και η τιμή του.

Να αναπτύξετε αλγόριθμο ο οποίος:

α) διαβάζει τα παραπάνω στοιχεία για κάθε βιβλίο.

β) εμφανίζει το πλήθος των βιβλίων του Ντοστογιέφσκι.

γ) εμφανίζει, το μέσο όρο της τιμής των 150 βιβλίων.


[5] Να αναπτύξετε αλγόριθμο ο οποίος για κάθε έναν από 10 αθλητές:

α) διαβάζει το μήκος του άλματος κάθε αθλητή. Θεωρήστε ότι για άκυρο άλμα δίνεται ως μήκος ο αριθμός μηδέν (0).

β) εμφανίζει το πλήθος των αθλητών που είχαν άκυρη προσπάθεια.

γ) εμφανίζει το μέσο όρο μήκους των έγκυρων αλμάτων.

Αλγόριθμος που εμφανίζει το y ανάλογα με την τιμή του χ

Αλγόριθμος άσκηση
Δεδομένα // χ //
Αν χ  -2 και χ < 0 τότε
y  χ^2 + 5
αλλιώς_αν χ  0 και χ < 4 τότε
y  χ/(χ + 4)
αλλιώς_αν χ  4 και χ < 15 τότε
y  Α_Τ(χ)
Τέλος_αν
Εμφάνισε y
Τέλος άσκηση

Επαναληπτικές ασκήσεις σχετικά με κατηγορίες προβλημάτων, τιμή μιας μεταβλητής, διάστημα τιμών μιας μεταβλητής, τελεστές, αναπαράσταση αλγορίθμων, βήματα αλγορίθμου

Σε ποια κατηγορία ανήκει καθένα από τα παρακάτω προβλήματα;

 

Για το τέλος μερικές ακόμη ασκήσεις στην αναπαράσταση αλγορίθμων και στα βήματα ενός αλγορίθμου.

Άσκηση στη 2.2.7.2 Δομή ακολουθίας

Να αναπτύξετε αλγόριθμο ο οποίος:

α) εκχωρεί σε μία μεταβλητή το επώνυμό σας.

β) εκχωρεί σε μία μεταβλητή το βαθμό που λάβατε στο Α΄ τετράμηνο στο μάθημα «Ιστορία» της Α΄ Λυκείου.

γ) εκχωρεί σε μία μεταβλητή το βαθμό που λάβατε στο Β΄ τετράμηνο στο μάθημα «Ιστορία» της Α΄ Λυκείου.

δ) υπολογίζει τον ετήσιο προφορικό βαθμό σας που προκύπτει από το μέσο όρο των βαθμών των δύο τετραμήνων.

ε) εκχωρεί σε μία μεταβλητή το βαθμό που λάβατε στις προαγωγικές εξετάσεις στο μάθημα «Ιστορία» της Α΄ Λυκείου.

στ) υπολογίζει τον βαθμό προαγωγής που προκύπτει από το μέσο όρο του ετήσιου προφορικού βαθμού του μαθητή με τον βαθμό που έλαβε στις προαγωγικές εξετάσεις.

ζ) εμφανίζει το επώνυμο του μαθητή και τον βαθμό προαγωγής.

Δημιουργία διαγράμματος ροής για αλγόριθμο που περιλαμβάνει τη δομή επανάληψης ΟΣΟ

Δίνεται ο παρακάτω αλγόριθμος σε ΓΛΩΣΣΑ:

ΑΛΓΟΡΙΘΜΟΣ Ασκηση1

χ <- 5

ψ <- 7

ζ <- 0

ΟΣΟ ψ > 0 ΕΠΑΝΑΛΑΒΕ

   ΑΝ ψ mod 2 = 1 ΤΟΤΕ

      ζ <- ζ + χ

   ΤΕΛΟΣ_ΑΝ

   χ <- χ*2

   ψ <- ψ div 2

   ΓΡΑΨΕ χ, ψ, ζ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ζ

ΤΕΛΟΣ Ασκηση1

 

Τί θα εμφανίσει στην οθόνη του υπολογιστή ο αλγόριθμος κατά την εκτέλεσή του;

Να σχεδιάσετε το αντίστοιχο διάγραμμα ροής.